Note: this procedure requires that you create an .img file from the .iso file you download.
Tip: Drag and drop a file from Finder to Terminal to 'paste' the full path without risking typing errors.
- Download the ISO you need.
-
Open the Terminal
-
Convert the .iso file to .img using the convert option of hdiutil
"hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/<*.iso>)
Note: OS X tends to put the .dmg ending on the output file automatically. -
Run "diskutil list" to get the current list of devices.
-
Insert your flash media.
-
Run "diskutil list" again and determine the device node assigned to your flash media (e.g. /dev/disk2).
-
Run diskutil unmount Disk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2).
-
Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).
- Using /dev/rdisk instead of /dev/disk may be faster
- If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M
- If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive
-
Run diskutil eject /dev/diskN and remove your flash media when the command completes.
-
Restart your Mac and press alt/option key while the Mac is restarting to choose the USB stick.